Photoshop CS6 – Editing Images

Auto Color Correction

The Auto Color Correction options control the automatic tone and color corrections available in both Levels and Curves. It also controls the settings for the Auto Tone, Auto Contrast, and Auto Color commands.

To use the Auto Color Correction Tool, we need to add either a Level or a Curves Adjustment to our image. There are a couple ways of doing this.

1. Click on the Levels or the Curves icons in the Adjustment Panel
   a. This will create a new Layer on your image, either named Levels 1 or Curves 1, depending on which adjustment layer you choose.
2. Click on the Layer Menu, New Adjustment Layer, Levels...or Curves...
   a. This option will allow you to name the new layer. The default name is Levels 1 or Curves 1, depending on which option you choose.

Tip: Auto Tone, Contrast, & Color can also be applied to an image file the Image Layer, but when you do the Adjustments through the Image Menu, you are physically changing the pixels within the image.

Levels or Curves Adjustment?

Levels: Three points of Adjustment. Shadows, Midtones and Highlights. Auto works really well.

Curves: More control points for adjustment. We can have up to 16 points of adjustment. May need to adjust after Auto. Allows for more drastic changes.

When our new adjustment layer panel appears, there is an Auto button. By selecting the Auto button, we will apply an auto color to our image. You will notice that the Levels or Curves display will change. We can adjust the levels on our own after we do the Auto Color, but clicking and dragging with our mouse in the Levels or Curves display. We can also see a before and after by pressing on the eye icon on the bottom of the panel.
Another option we can do within our Levels or Curves is to press and hold the Alt key and then left click on the Auto button.
In the Auto Color Corrections, we have a couple Algorithms to choose from;

- **Enhance Monochromatic Contrast**: (The Auto Contrast command uses this algorithm.) Clips all channels identically. This preserves the overall color relationship while making highlights appear lighter and shadows appear darker.
- **Enhance Per Channel Contrast**: (The Auto Tone command uses this algorithm.) Maximizes the tonal range in each channel to produce a more dramatic correction. Because each channel is adjusted individually, Enhance Per Channel Contrast may remove or introduce color casts.
- **Find Dark & Light Colors**: (The Auto Color command uses this algorithm.) Finds the average lightest and darkest pixels in an image and uses them to maximize contrast while minimizing clipping.
- **Enhance Brightness and Contrast**: this is the default action when we press the Auto key.

We are able to cycle each one of these options to see how they effect out image before accepting the effect.

When you have made the adjustments that you are satisfied with, click on the panel collapse icon to hide the panel.

We now have a Levels or Curves adjustment layer on top of our original image. We can toggle the adjustment on and off by clicking on the eye icon. We can also open the adjustment layer to make changes by double clicking on the adjustment layer icon within our Levels or Curves layer.

**Auto Black and White**

Auto Black and White works the same as the Levels and Curves Adjustment layer. We can add a Black and White adjustment layer by clicking on the Black and White icon, or by clicking on the new adjustment layer on the bottom of the layers panel and select Black and White.

By clicking the Auto button, Photoshop will convert our image to a Black and White image. If we are not satisfied with the end result, we can adjust how light or dark we want specific colors to display. If we drag the red toggle to the left, reds will display darker, if we
drag it to the right, they will display lighter.
Clone Stamp Tool

The Clone Stamp tool is great for removing imperfections such as dust and scratches, repairing defects and eliminating and/or adding elements within the image. This tool can be used to copy one portion of an image over another.

Aligned Option

This option keeps the cursor and the crosshairs relative to each other. When the Aligned option is left unchecked the Rubber Stamp repeats the cloning from the original location.

- Select the Clone Stamp tool from the toolbox
- Mouse over the area to be edited and decide which paint brush size will work best.
  - **Note:** You may have to change the zoom level.
- Position the cursor over the area from which you want the pixels to be cloned from and press and hold the Alt key. While pressing the Alt key, your cursor will change into a “target” symbol. This is where you are setting your Sample location. To set the location, while still holding the Alt key, left click with your mouse.
- Once you have set your sample point, you can now use the Clone stamp tool to paint over the image to be edited. The data from the pixel sample will be painted (cloned) to your image.
  - **Note:** The Clone tool paints whatever is attached to the crosshair of the tool. As you move your mouse up, down, left or right, the crosshair will move as well.
- You may have to make a new clone sample from time to time to get the best result.

Pattern Stamp Tool

The Pattern Stamp tool is used to copy a pattern and apply it to a different location in the same image or on a different image.

- Open the image with the pattern you want to copy
- Choose **Select | All** or use the rectangular marquee and make a selection
- Choose **Edit | Define Pattern**
- Provide a unique name for the pattern
- Click on the Ok button

To place the Pattern:

- Open a new file or work from an existing file
- Select the Pattern Stamp Tool
- Select a brush size from the Brush Palette
- Select the Pattern from the Options bar drop down menu

- Left click and paint the pattern over the image.
  - **Note:** Your pattern will repeat itself as you move through the confines of the selection you made when defining your pattern.
**Spot Healing Brush Tool**

The Spot Healing Brush Tool paints matching texture, lighting, transparency and shading to the affected area by sampling pixels around it.

The Spot Healing tool is an easy tool to quickly touch up “blemishes” on an image.

**Tip:** It may be helpful to duplicate the layer that you are using the Spot Healing Brush tool on because as you are touching up the image, you are also changing pixel information.

**The Healing Brush Tool**

The Healing Brush Tool is very similar to the Clone tool, where parts of an image can be copied and applied to other areas on the image or different images. You must also define a sample/source point in order to the tool to work. The major difference is that the Healing Brush tool matches texture and lighting, whereas the Clone tool paints over the pixels.

Start by selecting the Healing tool from the toolbox. From the Options toolbar select a brush that fits the area to be copied. Next, select an area that you want to copy and press Alt-click button (Ctrl-Click Mac) to copy it. Move the cursor to the area you want to copy to, left-click and drag the Healing tool over the area.

**Tip:** If you leave the Aligned option unchecked then every time you paint with the Healing brush it will repeatedly clone from the same place in the image, until you take a new sample for the tool.

**The Patch Tool**

The Patch tool works similar to the “healing” tools where sampled pixels are applied to flawed areas of an image. The Patch Tool also takes texture and color into consideration, when being used.

**Tip:** The Patch Tool is the perfect tool to use when repairing old images that have scratches or flaws.

Start by selecting the Patch Tool from the toolbox. The Patch tool is located behind the Healing tool in the toolbox.

When the Patch tool is selected, the tool icon on the canvas changes to a lasso. Depending on which option is selected in the Options bar, Source or Destination, you will both draw a selection around a flawed area and drag it over to an area that should be used as a “patch” or vice versa.

**Source Option** – When using the Source option, select an area that you want to modify, and then drag the selection over to an area that you would like to use as a “patch”.

© Computer Applications Training
Colorado State University
**Destination Option** – When using the Destination option, select an area that you would like to use as a patch over an area that needs repair.

**Content Aware**

The Content Aware tool can be used to remove objects from an image. Content Aware uses nearby pixel information to fill in the selection that is made.

Example: In the image below, remove the wrist band and part of the straw

Make a selection around the part of the image that you want to correct, and then go to Edit, Fill. In the Contents Drop-down, select Content-Aware, click OK.

Content aware samples the data around the selection to fill and reconstruct the area.

**Note:** You may need to use additional touch-up tools when using the Content-Aware tool to get the best end result.
**Red Eye Tool**

The Red Eye tool, which is located under the Spot Healing Brush Tool, is a great tool to use in order to remove the “red” eye from an image. Select the Red Eye tool and click in the red portion of the image. The tool will darken the pupil and retain its tonality and texture of the eye.

**Quick Selection & Refine Edge Tools**

The Quick Select tool in combination with the Refine Edge tool is a great way to select an object and remove it from a busy background. The Refine Edge tool refines the selection to get more detail, such as hair, when making/modifying a selection.

- Select the Quick Selection tool from the toolbar.
- Left click and drag over image to make a selection
- Alt-left click to remove part of a selection
- Once you have a selection, select the Refine Edge button
Refine Edge Options:

**View Mode:** Select a preview mode for the object so that it’s easier to work with.

**Smart Radius:** use the Smart Radius to have Photoshop adjust the hard/soft edges of the selection border.

**Radius:** Radius will define the size of the selection border. Increase the radius to improve the selection edge in order to display more detail.

**Smooth:** Smooth helps soften the jagged edges of the selection.

**Feather:** Feather will soften the edges.

**Contrast:** Contrast helps refine the edges and tighten the edges. Tip: use the Smart Radius tool before using the Contrast tool.

**Shift Edge:** The Shift Edge tools will modify the selection border, increase/decrease pixels.

**Decontaminate Colors:** Decontaminate removes fringe from the selection, which is from the original background of the image.

**Output:** Determines where the result of the refine edge will be placed. If you change the Output value to New Layer, your refined edge selection will be put on its own layer.
**Puppet Warp**

Puppet Warp lets you modify and move parts of an image → Transform an image.

The Puppet Warp tool is located under the Edit menu. The tool works best when you isolate the part of the image that you want to warp and put it on its own layer.

Select the object of the image to warp, copy it, and paste it into a new layer.

**TIP:** Copy the selection and paste it on its own layer. Press CTRL-C or copy, add a new layer in the layers palette, CRTL-V for paste on the new layer.

Next, select Puppet Warp from the Edit, Menu.

**TIP:** Turn your image into a smart object before selecting. Right click the mouse on the image and select Smart Object.

**Density:** if you need to add a lot of pins, you may have to change the Density:

**Mode:** Distort, Normal, Rigid

Rigid won’t be as flexible

Distort will be more distorting
Normal is middle of the line.

**Show Mesh:** Deselect to display only the pins, and not the mesh.

Click on the image where you want to add pins. Pins will appear as black circles.

**TIP:** Use more than one pin so you can transform the image.

Remove a pin by pressing the Alt key and clicking on a yellow circle, or by right clicking on the pin and selecting delete pin.

**Pin Depth:** Use the Pin Depth to move the transformed piece behind or in front of the selection.

**Tools in the upper right corner of the options bar:**

Select the Undo button to remove all transformation
Select the No button cancel

© Computer Applications Training
Colorado State University
Select the Check Mark accept

**Layer Mask Exercise**

A layer mask will determine whether an image is visible, invisible or partially invisible. Layer masks do not permanently change or remove pixels in an image.

**Objective:** Make it appear that the Zebra is looking through the Porthole.

**Modify a Selection with the Quick Mask Mode tools.**

Notice the selection is not very precise. Modify the selection with the Quick Mask Mode tools.

- From the Toolbox select the Edit in Quick Mask Mode button.

The non-selected area is displayed in a Red shade. The default color for the Edit Quick Mask Mode is Red. Sometimes the color Red is hard to use when selecting a portion of the image that is the same color. To change the Quick Mask Mode Color double-click on the Edit Quick Mask Mode button in the toolbox.

A Quick Mask Options dialog box will display. Click on the Color chip and select a new color for the Quick Mask Mode.

When using the Quick Mask tools reset the Foreground and Background color chips in the toolbox to the default colors of Black and White.

Click on the small Foreground and Background icon located in the lower left hand corner of the Foreground and Background Color Chip tool to reset the default colors for the Foreground and Background Color Chip tool.

From the Toolbox select the Paintbrush tool. The Paintbrush tool will be used to select and deselect areas of the image. **Note:** don’t forget to change the Paintbrush size to fit the area you are trying to select.

When painting with the Foreground color of Black the Quick Mask Mode will paint the selected area with the color used in the Quick Mask Mode.

When painting with the Foreground color of White the Quick Mask Mode acts as an eraser and can be used to remove the selected areas.

Click on the double arrow located in the upper right hand corner of the Foreground and Background Color Chip tool to toggle between the White and Black colors chips while using the Quick Mask Mode.
When finished selecting the area of the image exit the Edit Quick Mask Mode by click on the Edit in Standard Mode button that is located in the toolbox next to the Edit Quick Mask Mode button.

The area displayed on the screen shows the selected area of the image. Since this selection took a little work we should Save the selection in case we need to use it later on.

**Saving a Selection:**

Click on the Paths tab from the Layers Palette. Nothing is displayed at this point.

Click on the arrow to the right of the Paths tab to open the Path Menu.

From the Path Menu select Make Work Path.

From the Make Work Path dialog box a Tolerance needs to be set. The smaller the tolerance the more accurate your selection will be. Go with the default of 0.5 pixels.

Notice the Paths Palette now displays the shape of your selection. The default Path Name is Work Path. Rename the work-path by double clicking on the name and typing in a new name. This will save the Path.

Notice the Path Palette now displays the Path name as Zebra instead of Work Path.

To display the selection at a later time, select the Path from the Path Palette. Open the Path Menu and choose Make Selection. The “marching ant” selection will display on the image.

**Applying the Layer Mask:**

- Select the Layers Palette. There should be three layers in this exercise.
- Select the Zebra layer from the Layers Palette.
- Transform and resize the zebra. Edit, Transform, Scale.
- To add a Layer Mask choose Layer, Layer Mask, Reveal All.
- Select the Paintbrush from the toolbox. Paint with Black to make portions of the Zebra invisible and paint with White to make portions of the Zebra visible.
- When finished and happy with the end result be sure to link the Porthole layer and the Zebra layer together. Linking the layers together will allow the layers to be moved together when using the Move tool.
Linking Layers

Select the Zebra layer.

Left-click with the mouse in the little box to the right of the Eye icon on the Porthole layer.

A Chain Link will appear. The Chain Link icon represents a linked layer.

- Select the Move tool and move the Zebra. The Zebra and the Porthole should move together if linked correctly.

More Selecting Options

- Select all pixels on a layer within the canvas boundaries by choosing Select All, Ctrl+A, from the Select Menu.
- Deselect a selected area of an image by choosing Deselect from the Select Menu.

TIP: If you are using the rectangular marquee, elliptical marquee, or lasso tool, click anywhere outside the selected area to deselect or press Ctrl + D.

Reselect the most recent selection by choosing Reselect from the Select Menu.