Creating Charts/Graphs in Excel 2013

Charts are used to make it easier to understand large quantities of data and the relationship between different series of data by displaying series of numeric data in a graphical format. When you create a chart in Excel you will first enter the data on a worksheet and then create the chart. Excel automatically links the data to the chart so that if data is altered, added or deleted, the chart will update accordingly.

Chart Terms
You should be familiar with chart terminology so you will know the name of the object you wish to modify/add, etc. A typical style of chart would have an X-axis (horizontal) and a Y-axis (vertical). Below is a chart with its main aspects labeled.
A few guidelines for creating charts:

1) Different chart types are suitable for displaying different data sets. For example, a pie chart only displays one series of data, and would therefore be unsuitable for trying to compare more than one data range.

2) Generally speaking, simpler is better. Cluttering a chart with unnecessary data or too many additional objects may dilute the message you are trying to present with a chart.

3) You may need to consolidate some of your data in order to effectively present it in a chart. For example, you may want to present subtotals for your categories rather than plotting individual data items. Using the built-in subtotals feature of Excel (Data Tab, Subtotals) can often be useful in summarizing the data before plotting it.

4) Charts may be created in Excel and then pasted into other applications such as PowerPoint or Word. By default, the chart is pasted as a link so that if the data changes in Excel, the chart’s view will update in any other application where it was pasted.

Types of Charts
Below are some general guidelines for selecting the best type of chart for the data you wish to present.

<table>
<thead>
<tr>
<th>Chart Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Column</td>
<td>Shows data changes over a period of time or illustrates comparisons among items</td>
</tr>
<tr>
<td>Line</td>
<td>Shows trends in data at equal intervals</td>
</tr>
<tr>
<td>Pie</td>
<td>Shows proportional size of items that make up a data series; only shows 1 data series</td>
</tr>
<tr>
<td>Bar</td>
<td>Illustrates comparisons among individual items</td>
</tr>
<tr>
<td>Area</td>
<td>Emphasizes the magnitude of change over time</td>
</tr>
<tr>
<td>XY (scatter)</td>
<td>Shows relationships among numeric values in several data series or plots two groups of numbers as one series of XY coordinates.</td>
</tr>
<tr>
<td>Stock</td>
<td>Measures volume and has two axes; one for measuring volume, the other for stock prices</td>
</tr>
<tr>
<td>Surface</td>
<td>Shows optimum combinations between two sets of data (like a topographic map)</td>
</tr>
<tr>
<td>Doughnut</td>
<td>Shows the relationships of parts to a whole, like a pie, but can contain &gt;1 data series</td>
</tr>
<tr>
<td>Bubble</td>
<td>Type of scatter chart; compares 3 sets of values with the 3rd displayed as a size of a bubble</td>
</tr>
<tr>
<td>Radar</td>
<td>Each category has its own value axis radiating from the center point</td>
</tr>
<tr>
<td>Cone, cylinder &amp; pyramid</td>
<td>Creates the specified effects by using shaped data markers in 3-D column and bar charts</td>
</tr>
</tbody>
</table>
Creating a Chart
Select the cells that contain the data and text you want to include in the chart. Select both the numeric data and adjacent row and column headings. Make sure there are no blank rows or columns between the title and category headings and the body of the data or Excel will plot the blank spaces. Navigate to the Insert tab, Charts group, and select a chart type from the Ribbon.

You will see several options for chart types, and then options for each chart type. You are able to preview the charts by clicking on a chart type, and highlighting over the options under a column chart for example. Excel will show you a live Preview of the chart.

Sizing, Moving, and Deleting a Chart
To size the chart, drag the sizing handles until the chart reaches the desired size.

To move the chart within the same worksheet, simply click on the chart until your cursor turns into a plus sign with 4 arrows. Now click hold and drag the chart to a new location.
To move the chart to another sheet, select the chart, choose Cut, Go to the new location, position the cursor and choose Paste. You may also click on the chart, navigate to the Chart Tools Design Tab, and then select the Move Chart icon. You will have the option to move the chart to a new worksheet which you can name, or to move it into a current worksheet.

To delete a chart, click on it to select it, press the Delete key on your keyboard.

The same process will work to delete any chart element such as a data series, legend, or title. Click on the element to select it, then press Delete.

**Selecting Data**

If you don’t have your data selected prior to selecting your chart type, or if you had the wrong data selected, you can always change your data by right click the mouse on the chart and choose Select Data from the context sensitive menu.

From the Select Data Source window, make sure your cursor is in the Chart data range text box, now navigate your mouse back to the worksheet holding your data. Now click hold and drag your cursor to select the data that you want to be displayed in your chart. When you have the correct data, hit the OK Button.
You may also change your data from the Chart Tools Design Tab, and then clicking on the Select Data icon.

Quick Analysis Tool

The Quick Analysis Tools, which is new to Excel 2013, allows you to select or highlight data and quickly analyze using a few options such as Formatting, Charting, Totals, etc.

To use the Quick Analysis Tool, select your data, on the bottom right of your selection you will see the Quick Analysis Tool icon. Click on the icon to see what options you have.

The top tabs will offer various options as to what you can do with your data. You are able to mouse over any option to see a live preview of each tool, so you can see how your data will look before selecting a change to your data.

If you click on Charts tab, you are able to see what Charts are available. You are able to mouse over the options to see a visual of the chart before actually selecting it. If none of the options will work for you, click on the More Charts icon to see all available chart options.
Swapping the Row/Column Data
After you have created a chart, you may choose reverse the series order of data, either on the X or Y axis. A quick way of doing this is by using the Switch Row/Column Data icon under the Chart Tools Design Tab.

Another way to do this is to click on the Select Data icon from the Chart Tools Design tab.

Add, Edit, Remove Series
From the Data Source dialog box you are able to orient your chart by Rows or Columns and it also allows you to change the data range if desired.

To Edit a Series, click on the name and click the Edit button. The Edit Series window comes up. The Series Name is the Cell that contains the name of the Series that will appear on your chart. The Series Values is the data that will be displayed on the chart.

By default, a data series is one category of your table. You can emphasize either the row or column data and may change back and forth within the Data Source dialog box to select the best view.
Recommended Charts

New in Excel 2013 is a feature called Recommended Charts. Recommended charts will look at your data and provide some recommendations for chart types to display your data. To use Recommended Charts, select the data that you want to display, click on the Insert Tab, and then select Recommended Charts.

The Insert Chart window appears with the recommendations for your data. You are able to click on any of the options on the left hand side and see a preview. If you find a chart that you want, either double click on it or select it and hit the OK button.
Notice that there are a few options available to you, but it doesn’t necessarily mean that these are going to be the correct chart for your data. If you don’t see an option that works, you can always click on the All Charts tab to pick the specific chart type that you would like to display.

From the All Charts tab, you are able to see all of the charts that are available, the different options for each type and a Preview. Once you have found the chart type that you like, either double click on it, or select it and hit the OK button. The chart will now be displayed in your worksheet.

**Changing the Chart Type**

When you create your chart and it does not display the information as you thought it may, simply select the chart and click on the Change Chart Type icon from the Design tab. This will bring up the All Charts tab which will allow you to see every chart available. You will also have the Recommended Charts tab that you can use to Preview the options that Excel provides to you. When you have found a chart that you like, double click on it or select it and hit the OK button.
Formatting Chart Elements
Before you can select and modify any chart item, the chart must be activated. Click on a chart to select it. You will see “selection” handles added to the border indicating it is active. After activating the chart, you can move, modify, and size various elements of your chart such as titles, data labels, and pie and doughnut slices by selecting and dragging them. You can move and resize the plot area, the legend, and any graphic objects, such as text boxes and arrows that you have created by clicking on the piece and dragging, resizing, etc.

When the chart is active, you will see 3 icons on the upper right side of the chart.

Chart Elements: Add, remove, or change chart elements such as title, legend, and gridlines
Chart Style: Set a style and color scheme
Chart Filter: Edit what data points and names are available on your chart

Chart Elements
Chart Elements will allow you to add, change, or remove chart elements. You can easily change the look of your chart by selecting, or deselecting any Element from the Chart Elements window.

Some the elements will have more options for their location on the chart. Any time you see a grey right arrow, you will have more options for the elements.

Remember: You are still able to move the Elements on the chart if you don’t like the exact locations of where they are located.

Note: These options are also available on the Chart Tools Design tab, under the Add Chart Element icon.
Chart Elements Options

Some Elements will have a More Options... option. This option will allow for formatting of the Box that the element is in as well as the text in the element.

The options that are available are dependent on which element you have selected the More Options option from. This is a good way to change the look of your chart elements.

Chart Style

The Chart Style will show you a few options of prebuilt Styles within Excel. You are able to click on any of the options to see a live change of your chart. If you do change the styles, you can always go back into the Filter option to change your chart back or to a new look.

The color option will allow you to change the colors of the chart. You are able to preview how they will look on the chart by clicking on the color options.

Note: Style and Color are both separate but can be used in conjunction with each other or on their own.

Note: These options are also available on the Chart Tools Design Tab.
Chart Filters
The chart filter will allow you to filter the data within your chart by selecting various Series or Category labels. To change the look of the chart, click the Apply button on the bottom of the Filter window. To get your chart back to the original look, click on the Select all check box to display all data.

On the Names tab you are able to add or remove the Series and Category names. To make a change take effect, click on the Apply button.
Chart Themes
An easy way to format your chart is to use the built-in themes from Excel. These are the same themes that are used in PowerPoint and Word. To change the theme, click on the Page Layout tab, then select the Themes dropdown. You will have several theme options that are available to use. You are able to mouse over the name of the theme and see how your chart will change before actually selecting the theme.

You may also use your own color selections by clicking on the Format tab under Chart Tools. If you change the color and text via the Chart Tools Format tab, you will have to select each element individually.
Chart Quick Layouts
Once you have created a chart, Excel has created some prebuilt Chart Layouts that may be useful. These options are available on the Chart Tools Design tab, under the Quick Layouts icon. There will be several options depending on the type of chart you are using. This is a quick and easy way to develop a chart with the information that you want to show.

You are able to see a live preview of any of the Layouts by moving your mouse over a particular layout. To select a layout to use on your chart, just click on the one that you want and your chart will be updated. If there are some elements on the chart that you don’t want, you can easily delete them or add in new elements.

Changing the Data Series Order
You can change the order in which the series are plotted for data series within the same chart type group (other than radar charts). From the Chart Tools Design tab, choose the Select Data icon. Specify the order you want the series to be in by clicking on a series name and using the arrow buttons to move the series name up or down.
Format a Data Series

When a data series is selected in the chart, you can right-click the mouse to adjust the Data Series. The following context sensitive menu appears:

On the top of the context sensitive menu, you can change the fill and/or outline of the data series. To get more options, select the Format Data Series...option on the bottom.

From the format Data Series option, you can also adjust the Fill and border, as well as adding a drop shadow, adding a 3-D effect, etc.

Changing Chart Text

When you create a chart, the data labels, legend entries, and axis tick-mark labels are created from and automatically linked to the worksheet selection the chart is based on. It is usually easiest to make changes to this text by editing cells on the worksheet. You can edit data labels directly in the chart, although this breaks the automatic link.

If you have added a chart title, axis titles, or text boxes (“floating text”) to your chart, you can select this text and type new text to replace it, or place the insertion point and edit it directly in the chart. Vertically aligned text is displayed horizontally until you are finished editing it.

Plotting Nonadjacent Selections

Sometimes the data you wish to plot are in rows or columns that are not adjacent to each other. To select and chart nonadjacent selections, begin by selecting the cells in the first row or column. Hold down the Ctrl key as you select nonadjacent areas. When you have all of the data selected that you want in your chart, go to the Insert Tab and select the type of chart that you want to display.
Inserting Shapes and Clip Art
To insert shapes into your chart, click on the Chart Tools Format tab. On the right hand side, you will see a selection of shapes. Click on the dropdown menu to see all of the shapes that are available. You can use the Shape Styles to change the look of your shape either before you insert your shape, or by selecting it after it is inserted and changing the look.

Copying a Chart into Microsoft Word
Once you have created your chart, you may need to share it in a report that you have created in Microsoft Word. To do this, make sure you have your Word Document open. Go back into Excel and make sure you have the chart selected. Copy the chart to the clipboard by clicking Ctrl-C. Now, navigate to your open Word Document and simply press Ctrl-V.

By default, the copied chart is linked back to the Excel worksheet. What this means is that any changes you make to the data in Excel, will be reflected on the chart in your Word Document. If you do not want the chart to change based on the data in Excel. After you have pasted your chart, in the lower right hand corner, you will see an icon with a clipboard and Ctrl. If you click on the Ctrl icon, you have the option to select different paste options. Click on the last icon, the Picture icon. This will paste a picture of your chart as it looks right now.