Discoverer Plus – A Report Writing Tool

Discoverer Plus, which is part of Oracle, is a new campus report writing tool that one can use to access the ODS (Operational Data Store). The ODS contains data from the Banner System (Student Data, Accounts Receivable, and some Financial Data) and Human Resource Data stored in views (tables – similar to Delphi tables). These views are defined in the ODS dictionary and can be accessed with Discoverer Plus, once granted login/password privileges for the ODS. Information can be displayed on the screen, printed, saved, shared, e-mailed or downloaded into Microsoft Access or Excel. Using an interface similar to Excel, create your custom report using Discoverer Plus tools in this 2 hour hands on class.

Getting Started with ODS and Discoverer Plus

Learn more about ODS and Discoverer Plus by visiting the following website maintained by Information System’s:

http://applprod.is.colostate.edu:9095/nfslib/work/discoverer.html

In order to use ODS and/or Discoverer Plus, you will need an ODS account. Complete the online Access Form and Application for ODS and Discoverer. The application link is located under the Documentation section of the Discoverer Home Page.

Once you receive access for ODS and Discoverer, you will be able to access the information in different ways.

Access ODS Information:

- Discoverer Plus
  A web-based online application in which you access data and create custom queries and displays according to your account privileges. Information queried in Discoverer can be saved in a workbook in ODS or there is an option to export the data to your local computer and import it into other applications such as Access or Excel. Note, workbooks can be “shared” with co-workers.

- Access or Excel
  If you have an ODBC (open database connectivity) connection on your computer and an ODS account, then you can Get External Data and either link or import data down into Access or Excel. The end-user should be knowledgeable in Access or Excel in order to manipulate the ODS data.
Accessing ODS/Discoverer

URL to access ODS/Discoverer:

http://discoprod.is.colostate.edu:7782/discoverer/plus

OR login to the Campus Administrative Portal and select Discoverer from the portal view.

https://cap.is.colostate.edu

**UserName and Password:**
type in the username and password given to you by the ODS Administrator.

**Database:**
The database to access is: **odsprod** (this is not case sensitive)

**End User Layer:**
Leave blank

Discoverer Components

**End User Layer (EUL)**

The Oracle’s Discoverer Administrator (Information Systems Staff) will define and create CSU’s EUL. The EUL consists of Business Areas and allows the connectivity between the end user and the data warehouse.
**Business Areas (BA)**

The Business Area’s are defined and created by the Oracle’s Discoverer Administrator. A BA is a collection of folders (similar to tables) of data.

An Example of different BA’s:

![Business Areas Diagram](image)

Tip: Only one Business Area can be viewed at a time.

**Folders**

Folders can also be described as a table. Each folder contains a collection of data, fields, that can be used in displaying data.

![Folders Diagram](image)

Tip: if folders are joined by a common field, then items (fields) from each joined folder can be used in a display.

Tip: Joined folders are active (not grayed out). Grayed out folders indicate no join availability to the selected folder.

**Items**

Items (or fields/columns) are stored within the Folders.

![Items Diagram](image)
The three types of items that a Folder can contain:

- **Axis Items** → item appears in either the top or side axis
- **Data Point Items** → items that contain a count or number value. Example: salary.
- **Aggregate Calculated Items** → display (Group by) a function used in a calculations

Example:

```
<table>
<thead>
<tr>
<th>SUM</th>
<th>AVG</th>
<th>COUNT</th>
<th>MIN</th>
<th>MAX</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
```

**Tip:** The Oracle Discoverer Administrator will create the different Item types and make them available to the end user.

**Workbooks**

Workbooks are a collection of data which is pulled from a specific BA, Folders, and Items. The data can be displayed on one or more worksheets within the workbook. The end user controls the creation, maintenance, deletion, and the display of the data on the different worksheets/workbooks.

**Tip:** When you save a workbook, the data remains in ODS, but the query to display your data lives in Discoverer Plus.

**Tip:** Workbooks can be “shared” to other users. Advantage? User doesn’t have to re-create the display of data.

**Creating a Workbook Using the Wizard**

The Workbook Wizard dialog box will appear when you login to Discoverer. The wizard is optional. If you would like to follow the wizard and create a workbook, then complete the tasks below, click on the Next button, until the wizard is finished. Bypass the wizard by choosing the Cancel button and work directly in Discoverer.

**Using the Wizard:**

From the wizard, select the option to open an existing workbook or create a new workbook.
In the following Wizard example, create a new workbook. Decide which objects to display in the worksheet.

Select the following for the first example:

- Title
- Page Items
- Table or Crosstab ***
- Graph (to be placed below the table)
- Text Area

***Layout Styles
Discoverer offers two different layouts when working with data displays.
1. Table
2. Crosstab

The two layout styles are defined below.
Table Layout

The Table Layout is a standard view where you have rows and columns of data. The columns contain your items (fields) and the rows contain the data (record) for that particular item.

Table with Page Item Layout

The Table with a Page Item Layout is the same as the Table Layout with the addition of a dropdown in the Page Item to quickly filter data by a specific value for the given Page Item.

Example of Table with Page Item Layout:

<table>
<thead>
<tr>
<th>Page Items:</th>
<th>College Description: Business</th>
<th>Department Description: Marketing</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Subject</td>
<td>Subject Description</td>
</tr>
<tr>
<td>1</td>
<td>BUS</td>
<td>Business-General-BUS</td>
</tr>
<tr>
<td>2</td>
<td>BUS</td>
<td>Business-General-BUS</td>
</tr>
</tbody>
</table>

Example: For the College of Business, Department of Marketing, display the data. Hide all other data.

Crosstab

A Crosstab is a process or function that combines and/or summarizes data from one or more sources into a concise format for analysis or reporting.

Example → For the given college, show the number of enrollments for each course number within each department.

<table>
<thead>
<tr>
<th>Page Items:</th>
<th>College Description</th>
<th>Agricultural Sciences</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Target Enrollment SUM</td>
<td>Actual Enrollment SUM</td>
</tr>
<tr>
<td>Agricultural and Resource Econ</td>
<td>0</td>
<td>1780</td>
</tr>
<tr>
<td>202</td>
<td>0</td>
<td>643</td>
</tr>
<tr>
<td>240</td>
<td>0</td>
<td>73</td>
</tr>
<tr>
<td>305</td>
<td>0</td>
<td>158</td>
</tr>
<tr>
<td>310</td>
<td>0</td>
<td>132</td>
</tr>
</tbody>
</table>

Step 2 of the Wizard

Select the appropriate BA in which folders and items will be selected from. For class purposes, select the ARIES Discoverer BA.
Next, select the folder that contains the items to display in the query. Expand the Course Schedule folder by clicking on the Plus sign to the left of the folder name.

Select the items to include in the query or display of data in the workbook/worksheet.

Example: Select Course ID, it should be highlighted in blue, to move it to the Selected Pane, click on the arrow pointing to the right.

Tip: Multiple items can be selected from a folder at one time. Click on the first item, Control-click on any other item to be added to the selection.

Tip: Select all fields in a folder by selecting the folder icon and then clicking on the arrow to move it to the Selected Pane.

Tip: Select a Range of items by selecting the first item and then Shift-clicking with the mouse on the last item in the selection range.

Step 3 of the Wizard

Step 3 of the wizard is providing options to change the layout of the worksheet. Leave everything as is for this example. Click on the Next button.
Step 4 of the Wizard

Step 4 of the wizard is asking about sort options. Leave everything as is for this example. Click on the Next button.

Step 5 of the Wizard

Step 5 of the Wizard is asking for Parameter Values. Example, when you load a workbook, you could have a parameter set to ask for a State value. When you type in the state value, only data meeting the parameter will display. Leave everything as is for this example. Click on the Finish button.

Another Way to Create a New Workbook

Create a new Workbook by choosing the File Menu, New or selecting the New Workbook icon from the Standard toolbar. Once New Workbook has been selected, Discoverer will walk you through the setup wizard.

The Workbook Window
Workbook Views

The View menu can be used to show/hide different screen components and toolbars. Shown (visible) items have a check mark displayed next to its name in the View menu. Click on the check mark to hide the item.

Saving a Workbook:

Save a Workbook by choosing File, Save As and provide a meaningful name for the Workbook. Note, all Workbooks are saved in ODS under the username. Note, when you save a Workbook, you are not saving all the data, you are saving your queries to display the data. Every time the workbook is opened, the data is refreshed.

Open a Workbook by choosing File, Open or selecting the Open icon from the Standard toolbar and selecting the appropriate workbook.
Edit Properties of a Worksheet within a Workbook

Edit Worksheet properties by selecting the Edit Worksheet icon located in the Standard Toolbar.

Worksheet Layout:

Use the Worksheet Layout tab to add/remove objects to the worksheet.

Select Items

Use the Select Items tab to add or remove items.
Table Layout

Use the Table layout tab to quickly add/remove Page Items or rearrange column layout.

Sort

Use the Sort tab to quickly add/remove a sort.

Parameters

Use the Parameters tab to quickly add/remove a worksheet Parameter.

Add New Worksheet or Duplicate Worksheet Data

Add a new Worksheet to the workbook by selecting the New Worksheet icon in the Standard toolbar. The wizard will open and assist with selection items for the worksheet.

Use the Duplicate as Table/Crosstab New Worksheet option from the Standard Toolbar to duplicate the data to a new worksheet and maybe use different options in displaying the data.
Adding a Title

The Title field displays at the top of the worksheet. When the Title field is set to display, double-click in the title area to open the Edit Title dialog box.

Type in the Title and use format the text accordingly.

Click on the OK button when finished.

If the Title field does not appear, then click on the Edit Worksheet icon in the Standard toolbar, navigate to Worksheet Layout and select the Title box.

Page Item

The Page Item field behaves as a filtering tool. The Page Item option can be turned on/off from the Edit Worksheet Properties, Worksheet Layout tab. You can have more than one Page Item displayed in the Page Item Field.

Example of a Page Item

For the given table, filter by a specific College and Department and only display data matching the Page Item criteria.
Change the Page Item criteria by selecting the drop-down arrow next to the Item (field) in the Page Item area and select a new item from the list. The data will refresh showing only what matches the Page Item criteria.

**Filtering**

Displayed data can be filtered to only show information that meets specific criteria.

Start the filtering process by selecting a unique value in a column and then selecting the drop-down menu for the Filtering icon. Select the filtering option and add the filtering criteria.

Once a filter has been applied, the Data will refresh. To edit/remove the filtering, select the Condition tab in the left navigation pane of the window. Select the filtering condition and click on the Edit icon (pencil icon).

Click on the Advanced button if you want to add more filtering criteria.

Example: Filter by College of Natural Sciences OR Business
Sorting

A Quick sort in Ascending or Descending order can be applied by selecting the Sort icon from the Standard toolbar.

To add a multi-level sort to your data, select the Tools Menu, Sort.

Click Add and then select a column to sort. Select the Group sort type to hide repeated cell values in a column. Check Hidden to hide a sorted column in the worksheet.

Select the Column, Direction, Sort Type and click on the Add button to add second sort criteria and so forth.
Conditional Formatting

Conditional Formatting to items that match specific criteria so that it stands out or appears differently than the rest of the data in the column.

From the Format Menu, select Conditional Formats.

Select the New Conditional Format button from the Conditional Format window.

Select the item to apply the conditional formatting to and select the formatting attributes.

Example: For the College of Business, display the data with the following formatting attributes of Bold, Text Color of White, and Background Fill Color to Blue.

<table>
<thead>
<tr>
<th>Item</th>
<th>Condition</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>College Catalog, College Description</td>
<td></td>
<td>Business</td>
</tr>
</tbody>
</table>

Select the Item and type in the Value.

Select the formatting attributes. The formatting attributes will only apply to items meeting the condition.

Click on the OK button when finished.
Cross Tab Example

A Crosstab is a process or function that combines and/or summarizes data from one or more sources into a concise format for analysis or reporting.

Example → For the given college, show the number of enrollments for each course number within each department.

<table>
<thead>
<tr>
<th>College Description</th>
<th>Agricultural Sciences</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Target Enrollment SUM</td>
</tr>
<tr>
<td>Agricultural and Resource Econ</td>
<td>0</td>
</tr>
<tr>
<td>202</td>
<td>0</td>
</tr>
<tr>
<td>240</td>
<td>0</td>
</tr>
<tr>
<td>305</td>
<td>0</td>
</tr>
<tr>
<td>310</td>
<td>0</td>
</tr>
</tbody>
</table>

Class Example:

Create a workbook, Crosstab worksheet, using items from the Course Catalog folder and the Course Offering Workbook.

Course Catalog fields:
Course Number
College Description
Department Description

Course Offering Fields
Target Enrollment
→ Click on the plus sign and select Sum (Schedule to Catalog option)
Actual Enrollment
→ Click on the plus sign for the field and select Sum
Note: while creating your cross tab, delete the Course Number. We will add the Course Number as a Drill (hierarchy) display.
Result of your crosstab:

<table>
<thead>
<tr>
<th>College Description</th>
<th>Target Enrollment SUM</th>
<th>Actual Enrollment SUM</th>
</tr>
</thead>
<tbody>
<tr>
<td>Agricultural and Resource Econ</td>
<td>0</td>
<td>1760</td>
</tr>
<tr>
<td>Animal Sciences</td>
<td>0</td>
<td>3805</td>
</tr>
<tr>
<td>Bioagricultural Sci &amp; Pest Mgt</td>
<td>0</td>
<td>1117</td>
</tr>
<tr>
<td>Coll of Agricultural Sciences</td>
<td>0</td>
<td>1430</td>
</tr>
<tr>
<td>Horticultural &amp; Landscape Arct</td>
<td>0</td>
<td>3228</td>
</tr>
<tr>
<td>Soil and Crop Sciences</td>
<td>0</td>
<td>1570</td>
</tr>
</tbody>
</table>

Actual Enrollments are displayed for each department within the selected college at the Page Item level.

Display the number of enrollments per Course Number for each department. Easily display the number of enrollments per Course Number by setting up a Drill, a hierarchy.

Set up a Drill by clicking on the arrow to the left of the Department Name. The system will pause for a short time and display Drill to Related link, click on it.

Select the Course Number for the Drill.

Click on the OK button.
Subtotals

Add a subtotal to certain categories in a display.

From the Tools Menu, Select Totals

From the Edit Properties dialog box, select the New button at the bottom of the window, and select New Total.

From the New Total dialog box, select the type of total needed.

Example: Subtotal Option @ the Department Level Description.
The Default Heading Name for the Total is “Sum”.

Change the label by deselecting the check box for Generate Label Automatically

Format Heading Button and Format Data Button (format the same so they stand out)
Edit your Total by selecting Tools, Totals

From the Edit Worksheet dialog box, select the Total Calculation and click on the Edit button.

Tip: you can right-click with the mouse on the calculation and choose Edit
Creating a Grand Total at the bottom of the page:

From the Tools Menu, select Total, and the New total button.

Select Sum as the function for Actual Enrollment, Grand Total at bottom, and edit the labels/formatting.

Editing the Grand Total can be done from the Calculations tab or from the Tools, Total menu.
This example shows subtotal at each Department and then an overall Grand Total

<table>
<thead>
<tr>
<th>Department Description</th>
<th>Target Enrollment SUM</th>
<th>Actual Enrollment SUM</th>
</tr>
</thead>
<tbody>
<tr>
<td>Construction Management</td>
<td>0</td>
<td>8447</td>
</tr>
<tr>
<td>Design and Merchandising</td>
<td>0</td>
<td>3942</td>
</tr>
<tr>
<td>Food Science &amp; Human Nutrition</td>
<td>0</td>
<td>4532</td>
</tr>
<tr>
<td>Health and Exercise Science</td>
<td>0</td>
<td>7621</td>
</tr>
<tr>
<td>Human Devpt &amp; Family Studies</td>
<td>0</td>
<td>4039</td>
</tr>
<tr>
<td>Occupational Therapy</td>
<td>0</td>
<td>1768</td>
</tr>
<tr>
<td>School of Education</td>
<td>0</td>
<td>8175</td>
</tr>
<tr>
<td>School of Social Work</td>
<td>0</td>
<td>2931</td>
</tr>
<tr>
<td><strong>Total by Department</strong></td>
<td></td>
<td><strong>4183</strong></td>
</tr>
</tbody>
</table>

Calculating a Percentage of the Whole

For the given example, calculate the percentage value for actual enrollment per course number.

From the Tools Menu, select Percentages to display the New Percentage dialog box.

Select Subtotal at each change in Department Description.

Format the Labels.

Click on the OK button when finished.
Setting Workbook Properties

From the Tools menu, select Options to display the Options dialog box.

The tabs displayed have default settings for how a workbook will behave and look. The settings set in this dialog box follow the user login information.

Sharing Workbooks with Others

Once a workbook is created, it can be shared with other users who have an ODS account. To share a workbook, open the workbook and select the File Menu, Share. Search for the user, select the user and click on the OK button to share it.

Tip: you can only share workbooks that you own.
Exporting Data

Queried data can be exported to Excel or other file formats and imported into other applications.

For Example, for a given workbook that is open, choose File, Export to Excel.

Note: This will not provide a save location on your local computer. The default save location is located in the Document Settings on the C: drive.

To choose how the data will be exported and select a storage location on the local computer for the export, choose File, Export and follow the wizard.

Page Setup Options

To add/edit page properties such has Page Orientation, Margins, and Header/Footer information, select the File Menu, Page Properties.

Select the formatting attributes for each tab and press the OK button when finished.